RESOLVED FIXED 62196
Allow drawing a slider thumb for any nodes
https://bugs.webkit.org/show_bug.cgi?id=62196
Summary Allow drawing a slider thumb for any nodes
Kent Tamura
Reported 2011-06-07 01:20:53 PDT
We currently support only drawing slider thumbs which are children of RenderSlider. Support grandchild thumbs too.
Attachments
Patch (15.50 KB, patch)
2011-06-07 02:29 PDT, Kent Tamura
no flags
Patch 2 (40.54 KB, patch)
2011-06-07 21:22 PDT, Kent Tamura
dglazkov: review+
Kent Tamura
Comment 1 2011-06-07 02:29:33 PDT
Dimitri Glazkov (Google)
Comment 2 2011-06-07 09:59:22 PDT
Comment on attachment 96221 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=96221&action=review I am not thrilled about adding shadow DOM-related functions to RenderObject. It seems like an abstraction leak. But I know you're fixing an abstraction leak, so perhaps this will work out on the long term. > Source/WebCore/rendering/RenderObject.cpp:248 > +RenderObject* RenderObject::hostRenderer() const This should probably have a more descriptive name, like shadowNodeHostRenderer().
Kent Tamura
Comment 3 2011-06-07 20:58:59 PDT
(In reply to comment #2) > I am not thrilled about adding shadow DOM-related functions to RenderObject. It seems like an abstraction leak. But I know you're fixing an abstraction leak, so perhaps this will work out on the long term. ok, I changed the strategy. Renderers should retrieve required information via corresponding nodes, and we should avoid assuming a specific tree structure like o->parent()->isSlider().
Kent Tamura
Comment 4 2011-06-07 21:22:57 PDT
Created attachment 96371 [details] Patch 2
Dimitri Glazkov (Google)
Comment 5 2011-06-08 09:19:14 PDT
Comment on attachment 96371 [details] Patch 2 View in context: https://bugs.webkit.org/attachment.cgi?id=96371&action=review This looks pretty cool. > Source/WebCore/dom/Node.cpp:966 > +Node* Node::focusCheckDelegationNode() I think this name is a bit confusing. How about "focusDelegate"? Also, how does this correlate with the work that Ito-san is doing on focus in shadow DOM? > Source/WebCore/html/shadow/SliderThumbElement.h:-52 > - bool inDragMode() const { return m_inDragMode; } Whoo, this is cool!
Kent Tamura
Comment 6 2011-06-08 16:31:33 PDT
Comment on attachment 96371 [details] Patch 2 View in context: https://bugs.webkit.org/attachment.cgi?id=96371&action=review >> Source/WebCore/dom/Node.cpp:966 >> +Node* Node::focusCheckDelegationNode() > > I think this name is a bit confusing. How about "focusDelegate"? > > Also, how does this correlate with the work that Ito-san is doing on focus in shadow DOM? I also thought it was not a good name. focusDelegate sounds good. I think this is not related to the Hayato's work. This is used only for focus rendering delegation. A slider thumb node doesn't have focus conceptually, but it should be rendered with the focus state of the owner <input>.
Note You need to log in before you can comment on or make changes to this bug.


OSZAR »